3by400 facebook   3by400 twitter   3by400 linkedin   3by400 google plus   3by400 blog feed

Have an account?  Login

RESULTS

HONESTY & EXPERIENCE

PARTNERSHIP

Top of Mind from 3by400

Our blog posts are the result of issues and opportunities we see in our daily work. They are designed to increase understanding and provide a source of vision for your web presence.

  • Home
    Home This is where you can find all the blog posts throughout the site.
  • Categories
    Categories Displays a list of categories from this blog.
  • Bloggers
    Bloggers Search for your favorite blogger from this site.
  • Archives
    Archives Contains a list of blog posts that were created previously.
  • Login
    Login Login form
Posted by on in 2011
  • Font size: Larger Smaller
  • Hits: 392
  • 0 Comments
  • Print

Why Should We Upgrade our Site?

Early next year, the next major release of Joomla will be released. It's currently slated to be called Joomla! 2.5. Don't ask me why, I didn't number it. Joomla 1.5 will thereafter hit end-of-live. Joomla 2.5 is scheduled to be supported for at least 18 months. Some of our client sites are Joomla 1.0, most are 1.5. We often get asked 'why should I have to upgrade my site? After all, it's working just fine.' And it may be, for the moment, but the sea is changing around it. When a piece of software reaches end-of-life, the developers quit maintaining it. This includes bug-fixes and security patches. Unfortunately, the bad guys don't lose interest in end-of-life software. In fact they actively start looking for vulnerabilities in older software, because they know the security holes won't be fixed. Along with this is

the changing landscape of everything around the site. We update the servers on a weekly basis with the latest upgrades of the version of Linux we're using (CentOS). This updates:

  • the operating system
  • the webserver
  • the PHP programming language
  • auxiliary programs like email

In the coming year, we'll probably be doing a major upgrade of PHP from the current 5.2.10 to 5.3.x. At some point, one of these upgrades may introduce new features or deprecate old features that will degrade the performance or even break older versions of Joomla. We'll be sad if that happens, but we have to do this maintenance to patch security issues and correct bugs.

Site degradation can come from other sources as well. One of our clients' Joomla 1.0 sites recently had its Google map quit working. This is because Google has changed their mapping software from version 2 that the site was using to version 3. Since it's a Joomla 1.0 site, there are no new Google maps version 3 components for it, so the site lost that functionality.

We've said it before, but it bears repeating: your website isn't like a picture that you hang on the wall and look at, it's more like a car that needs tune-ups and maintenance, or maybe more like an airplane that has to have its engine overhauled every so often. The major Joomla upgrades are like these engine overhauls: necessary for your site to keep running without unexpected breakdowns.

0

Comments